谷歌云

VMware Workstation 与 Device/Credential Guard 不兼容

我在系统升级到 Windows 10 2004 后,启动 VMware 的任一台虚拟机时会弹出错误提示框:

不兼容

嗯,图标题中的“lindexi”就是小伙伴林德熙;他在我的电脑上运行了一台虚拟机远程使用。然而怎么能随随便便就让虚拟机挂掉呢?得在他醒来之前偷偷修好。

提示框中的 Device/Credential Guard 就是 Windows 10 系统的“内核隔离”。

按照以下步骤逐一执行,直到修复。

特别前提
VMware 从 15.5.5 版本开始,已支持在启用了 Hyper-V 的 Windows 10 主机上运行:

使用 WSL 和 Device/Credential Guard 等功能时,用户仍可运行 VMware Workstation 虚拟机
需要 Windows 10 20H1 版本及以上系统
因此,如果你觉得不想折腾,直接将 VMware 升级到 15.5.5 以上即可。
15.5.5

图来自于 kkwpsv(李少珺)。

第一步:关闭内核隔离,然后重启
关闭内核隔离

要找到“内核隔离”开关,直接在开始菜单搜索“内核隔离”或者“Credential Guard”即可。如果搜不到,去任务栏右下角找到“Windows 安全中心”双击打开。
关闭内核隔离

第二步:禁用设备防护
打开“组策略”,进入 本地计算机策略 -> 计算机配置 -> 管理模板 -> 系统 -> Device Guard -> 基于虚拟化的安全性。

选择已禁用。

禁用基于虚拟化的安全性
禁用基于虚拟化的安全性

第三步:关闭 Hyper-V
在“启用或关闭 Windows 功能”里,关闭掉 Hyper-V 虚拟机(也需要重启)。

关闭 Hyper-V
第四步:运行命令
以管理员身份运行以下命令:

bcdedit /set hypervisorlaunchtype off

然后重启计算机。

文章来自:https://blog.walterlv.com/post/vmware-wants-to-disable-credential-guard.html

回复

This is just a placeholder img.